ISD ManageBac and Payment portal have been degrade performance due to Cloudflare CDN issues

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2023 - 15:17 GMT+06:00

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2023 - 14:57 GMT+06:00

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2023 - 14:14 GMT+06:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2023 - 15:13 GMT+06:00

Identified

The Cloudflare CDN's Dhaka network has been "re-routed" (reason is unknown), as a result ManageBac portal is now working slow from Bangladesh Public IPs network.

Cloudflare System Status Details: https://www.cloudflarestatus.com/
Posted Jun 01, 2023 - 08:31 GMT+06:00
This incident affects: ISD Official Website, ISD Official Messenger Site, ISD ManageBac, and ISD Online Payment Portal.